CompletedTelephony Maintenance
Status
Resolved after 8 days
Started
October 05, 2023 at 3:20 PM
Completed
October 13, 2023 at 11:20 PM
Affects
Website
Plum Voice Core Products
DEV
PCI DEV
FUSE
PCI Fuse
Insight
Plum Voice Services
Plum Voice SMS Service
Inbound Calling
Outbound Calling
- CompletedOctober 13, 2023 at 11:20 PMCompleted
- In progressOctober 05, 2023 at 3:20 PMIn progress
- PlannedOctober 05, 2023 at 3:20 PMPlanned