PCI Traffic

Resolved
Major outage
Started 11 months ago Lasted 32 minutes

Affected

Plum Voice Core Products
PCI DEV
PCI Fuse
Updates
  • Resolved
    Resolved

    This issue has now been resolved and all PCI traffic is now functioning normally.

  • Investigating
    Update

    Service disruption is observed to be intermittent. We are continuing to investigate.

  • Investigating
    Investigating

    We are currently experiencing issues exclusively impacting PCI traffic. Our team is currently investigating and we're looking forward to restoring services as quickly as possible.