Issues impacting call connection.

Resolved
Degraded performance
Started 11 months ago Lasted 2 days

Affected

Plum Voice Core Products
FUSE
PCI Fuse
Plum Voice Services
Inbound Calling
Outbound Calling
Updates
  • Resolved
    Resolved

    The issue has been resolved. Thank you for your patience.

  • Identified
    Identified

    Continuing our work from yesterday, our team is beginning maintenance and implementing our planned fix. All hands are on deck as work is underway. We will continue to monitor our systems throughout this process.

  • Monitoring
    Monitoring

    Mitigation has been implemented. We’ve observed intermittent slow connectivity but at this time services are operational. We are continuing to track this issue and are continuing our work on a permanent solution.

  • Investigating
    Investigating

    Call connection issues have returned, we are still all-hands-on deck working to readdress this issue. Mitigation is underway.

  • Monitoring
    Monitoring

    Our team has identified a few issues and has implemented mitigation steps at this time. We’ve observed intermittent slow connectivity but at this time services are operational.

  • Investigating
    Update

    Our team continues to remain vigilant in triaging this issue. We continue to make progress in resolving this issue and will keep providing updates as they are available. At this time, we have identified additional issues with outbound, all hands are still on deck working on this issue.

  • Investigating
    Investigating

    We are currently observing issues impacting call connection. Our team is all hands-on-deck currently investigating this issue. We will continue to provide updates as we have more information available.