Plum Voice - Outbound Calls and SMS Stuck in Queuing State – Incident details

By subscribing, you agree to receive recurring SMS status updates from Plum Voice. Message and data rates may apply. Text HELP for help, STOP to unsubscribe.

Outbound Calls and SMS Stuck in Queuing State

Identified
Major outage
Started about 14 hours ago

Affected

Plum Voice Core Products

Degraded performance from 7:27 PM to 12:38 AM, Partial outage from 12:38 AM to 12:00 AM

PCI Fuse

Degraded performance from 7:27 PM to 12:38 AM, Partial outage from 12:38 AM to 12:00 AM

Plum Voice Services

Partial outage from 7:27 PM to 8:08 PM, Degraded performance from 7:27 PM to 12:38 AM, Partial outage from 12:38 AM to 12:00 AM

Outbound Calling

Partial outage from 7:27 PM to 8:08 PM, Degraded performance from 8:08 PM to 12:38 AM, Partial outage from 12:38 AM to 12:00 AM

Updates
  • Identified
    Identified

    We've identified that the issue is continuing to impact outbound calls queuing, specifically to our PCI Fuse environment. We're actively working on a fix and will share updates as we make progress.

  • Resolved
    Resolved

    Outbound queuing behavior has returned to normal. Outbound services are operating as expected at this time.

  • Monitoring
    Monitoring

    We've identified the issue and restarted the necessary services. Outbound calls should begin processing, though there may be a slight delay as the backlog clears. We're continuing to monitor.

  • Investigating
    Investigating
    We’re currently investigating reports of outbound calls and SMS not processing as expected. The team is reviewing the underlying systems and will provide updates as they become available.