Plum Voice - Intermittent Call Failures for Some Fuse PCI Customers – Incident details

By subscribing, you agree to receive recurring SMS status updates from Plum Voice. Message and data rates may apply. Text HELP for help, STOP to unsubscribe.

Intermittent Call Failures for Some Fuse PCI Customers

Resolved
Partial outage 14 %
Started 6 days agoLasted 16 minutes

Affected

Plum Voice Core Products

Partial outage from 9:21 PM to 9:24 PM, Operational from 9:21 PM to 9:38 PM, Partial outage from 9:24 PM to 9:38 PM

PCI DEV

Operational from 9:21 PM to 9:38 PM

PCI Fuse

Partial outage from 9:21 PM to 9:38 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. It was scoped to affect both Fuse PCI and PS DEV customers leveraging the PCI environment who have not yet been migrated to the new infrastructure. System performance has stabilized, and normal operations have resumed.

  • Monitoring
    Monitoring

    We recognize there was impact to a subset of Fuse PCI customers. A fix has been implemented, and our team is currently monitoring the results to confirm stability.

  • Investigating
    Investigating

    We are currently investigating reports of intermittent call failures affecting a subset of Fuse PCI customers. At this time, not all Fuse PCI customers are impacted.

    Our engineering team is actively reviewing the issue and working toward a resolution. Additional updates will be provided here as more information becomes available.